Skip to Content

Yealink T58W-C 16 Line IP HD Android Phone with HD Camera, 7" colour touch screen, HD voice, Dual Gig Ports, Built-in Bluetooth Wifi, USB 2.0

Brand: Yealink SKU: 6938818307674
(0 review)

Product Code: 6938818307674

T58W and CAM50 camera





$ 573.30 $ 573.30

  • Availability
  • Brand
In stock
Ships in 1–2 business days
  • Australia Post Parcel & Express — live quote at checkout, Australia-wide
  • Prices include GST — tax invoice with every order
  • 30-day money-back guarantee
Add to wishlist
Terms and Conditions
30-day money-back guarantee
Shipping: 2-3 Business Days
Availability: In stock
Brand: Yealink

Key specifications

Brand Yealink
Our SKU 6938818307674
Barcode (EAN/UPC) 6938818307674

Specifications

Yealink SIP-T58W, IP Phone, Grey, Wired handset, In-band, Out-of band, SIP info, 1000 entries, LCD

Yealink SIP-T58W. Product type: IP Phone, Product colour: Grey, Handset type: Wired handset. Dual-Tone Multi-Frequency (DTMF) modes: In-band, Out-of band, SIP info. Phonebook capacity: 1000 entries. Display: LCD, Display diagonal: 17.8 cm (7"), Display resolution: 1024 x 600 pixels. Front camera resolution (numeric): 5 MP, Field of view (FOV) angle: 75°

Design
Product typeIP Phone
Handset typeWired handset
Product colourGrey
Wall mountableYes
Performance
Dual-Tone Multi-Frequency (DTMF) modesIn-band, Out-of band, SIP info
Hearing aid compatibilityYes
Phone features
Answering machineYes
Call waitingYes
Speed diallingYes
IntercomYes
Call holdYes
Call forwardingYes
Conference callYes
RedialingYes
Caller IDYes
Do not disturb functionYes
Phonebook capacity1000
Call parkYes
Call pick upYes
Anonymous callYes
Anonymous call rejectionYes
Full duplexYes
Call returnYes
Call transferYes
Message-waiting indicator (MWI)Yes
Management features
Integrated voicemailYes
Keypad number of keys27
Number of function keys7
Display
DisplayLCD
Display diagonal17.8
Display resolution1024 x 600
TouchscreenYes
Touchscreen typeCapacitive
Camera
Front cameraYes
Front camera resolution (numeric)5
Field of view (FOV) angle75
Audio
SpeakerphoneYes
Microphone muteYes
Voice codecsG.711a, G.722, G.723.1, G.726, G.729, G.729A, G.729B, iLBC
Noise reductionYes
Voice activity detectionYes
Adaptive jitter buffersYes
Automatic gain controlYes
Comfort noise generation (CNG)Yes
Packet loss concealment (PLC)Yes
Video
Video resolutions1280 x 720
Video codecsH.264 High Profile, H.264, VP8
Network
Ethernet LANYes
Ethernet LAN interface typeGigabit Ethernet
Ethernet LAN data rates1000
Wi-FiYes
Wi-Fi standards802.11a, 802.11b, 802.11g, Wi-Fi 4 (802.11n)
BluetoothYes
Bluetooth version4.2
Supported network protocolsIPv4/IPv6, SIP v1 (RFC2543), v2 (RFC3261), UDP/TCP/DNS-SRV (RFC 3263)
Quality of Service (QoS) supportYes
Security algorithms256-bit AES, HTTPS, TLS, WPA2, WPA3
Networking standardsIEEE 802.11a, IEEE 802.11b, IEEE 802.11g, IEEE 802.11n, IEEE 802.1x, IEEE 802.3af
Ports & interfaces
USB 2.0 ports quantity2
Ethernet LAN (RJ-45) ports2
RJ-9 ports quantity2
Power
Power over Ethernet (PoE)Yes
Operational conditions
Operating temperature (T-T)0 - 40
Operating relative humidity (H-H)10 - 95
Weight & dimensions
Width259.4
Depth220
Height239
Weight9.16
Package width324
Package depth293
Package height128
Package weight9.86
Packaging content
Number of handles included1
Logistics data
Harmonized System (HS) code85171800

Recently viewed